phpBBex 1.9.3, основанный на phpBB 3.0.14

Регистрация
28.10.2017
Сообщения
979
Решения
1
Реакции
196
Вышел phpBBex 1.9.3, основанный на phpBB 3.0.14. Теперь phpBBex 1.x поддерживает PHP 7.0+ и даже PHP 8.0!

Требования:
  • PHP 5.4+, 7.0+, 8.0.
  • MySQL 5.0+.
Что нового?
  • Поддержка PHP 7.0+
Наконец, появилась поддержка PHP 7.0+ и PHP 8.0. Переход на новую версию PHP даёт заметный прирост производительности и снижает нагрузку на сервер.

Минимальная версия PHP поднята с версии 5.2 до 5.4. Много старого кода в стиле PHP 4 было обновлено. К сожалению, скорее всего код старых модов тоже придётся немного подправлять, но обычно это требует каких-то достаточно простых и очевидных изменений. Более высокая производительность стоит того!

Другие полезные изменения
  • Удалены устаревшие заголовки из отправляемых писем так как они не нравились некоторым спам-фильтрам.
  • Исправлены размеры кнопок в стандартном стиле. Стиль создавался под Firefox образца 2008 года. Современные браузера отрисовывали кнопки меньше чем задумывалось, что и было исправлено.
  • Обновлены иконки кнопок социальных сетей на вариант от Sumanai. Удалена иконка Google+, так как он более не существует.
  • Улучшена поддержка HTTPS. Ссылки на тот же хост, но с другим протоколом (http или https) считаются внутренними.
  • Исправлены другие незначительные ошибки.

Обновление c phpBBex 1.8.0 или 1.9.0 до 1.9.3

Если у вас более ранняя версия, сперва обязательно выполните инструкцию по обновлению до phpBBex 1.8.0. После этого выполните следующие инструкции.
  1. Сделайте резервную копию вашего сайта
  2. Замените все файлы (кроме config.php!) предыдущей версии phpBBex.
  3. Запустите install/database_update.php.
  4. Не забудьте сбросить кэш в админке (на главной), обновить шаблоны, стили и наборы изображений.
Все ваши изменения придётся проделать повторно. Если у вас большое количество изменений, переносить их со старой версии форума на новую версию может быть утомительным. Вручную вносить правки из новой версии в вашу версию тоже плохой вариант — изменений слишком много. Для автоматизации процесса рекомендую освоить Git, и использовать последнюю версию движка из репозитория проекта.
 

Вложения

  • phpbbex_v1.9.3.7z
    1,5 МБ · Просмотры: 0
Регистрация
28.10.2017
Сообщения
979
Решения
1
Реакции
196
Верх